Author Topic: OpenBve Sdl Windows 8  (Read 4250 times)

Minecrafterboi

  • Freshman

  • Offline
  • *

  • 4
  • Karma:
    +0/-0
    • View Profile
OpenBve Sdl Windows 8
« on: July 28, 2013, 11:20:45 PM »
Hello I'm new here but umm I recently bought a new windows 8 laptop and I downloaded OpenBve on it and after I pick the train and route and press start the program says "sdl failed to initialize the video subsystem" does anybody know how to fix this?

Minecrafterboi

  • Freshman

  • Offline
  • *

  • 4
  • Karma:
    +0/-0
    • View Profile
Re: OpenBve Sdl Windows 8
« Reply #1 on: July 28, 2013, 11:25:29 PM »
Also My processor is AMD

Lashrathius

  • Freshman

  • Offline
  • *
  • [Head Admin]

  • 12
  • Karma:
    +100/-0
  • Personal Text
    (R) to Forest Hills Developer
    • View Profile
Re: OpenBve Sdl Windows 8
« Reply #2 on: July 29, 2013, 02:33:11 AM »
I'm running Windows 7 but to my understanding, you need to run OpenBVE as administrator on Windows 8 computers.

Minecrafterboi

  • Freshman

  • Offline
  • *

  • 4
  • Karma:
    +0/-0
    • View Profile
Re: OpenBve Sdl Windows 8
« Reply #3 on: July 29, 2013, 11:12:21 AM »
I tried that but it doesn't work

BCPTF

  • Freshman

  • Offline
  • *

  • 5
  • Karma:
    +0/-0
    • View Profile
Re: OpenBve Sdl Windows 8
« Reply #4 on: July 29, 2013, 06:17:49 PM »
Did you download all the program dependencies?
Also, try run under Compatibility Mode.
(I'm running 7, but these apply to 8 as well.)



Lashrathius

  • Freshman

  • Offline
  • *
  • [Head Admin]

  • 12
  • Karma:
    +100/-0
  • Personal Text
    (R) to Forest Hills Developer
    • View Profile
Re: OpenBve Sdl Windows 8
« Reply #5 on: July 29, 2013, 09:02:28 PM »
BCPTF is right. You need the correct program dependencies for OpenBVE to operate correctly. Install (or re-install) the following dependencies on this site EXCEPT for .NET, which is already included in Windows 8.

http://odakyufan.zxq.net/openbve/install.html

MRROSSNOW

  • Freshman

  • Offline
  • *

  • 21
  • Karma:
    +0/-0
    • View Profile
Re: OpenBve Sdl Windows 8
« Reply #6 on: February 09, 2014, 06:37:56 PM »
hey Guys I am having the same SDL wont intialize the video subsytem im on a mac PLZ HELP